By now, we all have heard of potential security problems and risks on the Internet. And most recently, we must worry about which Web browser we use.

Indeed, the U.S. Department of Homeland Security cautioned Americans last week to refrain from using Internet Explorer because of a significant security flaw.

This flaw apparently enables hackers to circumvent the Windows operating system's security protections. Once that happens, there can be "infection" caused when a compromised website is visited.

This type of hack reportedly attacks a victim's computer by using a corrupted Adobe Flash file. Accordingly, and importantly, users should be able to protect themselves by turning off Adobe Flash.

The security flaw was reportedly made public by an Internet security software company called FireEye Research Labs. Following FireEye's report, some tech pundits (and Homeland Security) recommended that other Web browsers be used instead of Internet Explorer until the flaw could be fixed.

By week's end, Microsoft had released a patch to address the IE security problem, which will automatically be installed if you have updates turned on. If you use IE and aren't set up for automatic updates, here are step-by-step instructions on how to do it.

While this specific problem potentially can impact Internet Explorer versions 6 through 11, "the attack is targeting IE9 through IE11," according to FireEye Research Labs.

Fortunately, the attacks related to this problem so far are not too prevalent -- despite the fact that more than 50 percent of PCs run on versions of Internet Explorer.